How do you keep your Baked Textures HD?

could u tell me how to keep your baked textures to remain HD in unity? Because whenever i import something from maya the textures degrade a ton from the actual texture thus providing crappy looking graphics. Could you help me? I uploaded some pictures for reference.

My guess is that you’re not setting up the default texture size. If you single-click on a texture you imported, one option in the Inspector window on the right is 'Max Size". Set that to whatever the resolution of your baked texture is.