How do you make blender models mesh colliders work right?

I imported a model from blender and added a mesh collider to it but the mesh option on it said none, so i tried adding one of the meshes of the model I imported and those meshes looked nothing like the actual object. I’m not sure what could cause this. Any suggestions?

If you have scaled and otherwise transformed the models at the object-level in Blender (not recommended), then the meshes will not have those transformations, and so look different.

In Blender, under Object->Apply in the 3D View, you’ll see options to apply the location, scale, and rotation. Do that (after making a backup if you don’t understand what this is actually doing).

Also note that the importer has a “Generate Colliders” option.