How I do re-install the webplayer when it fails to work?

I have tried to install the Unity Web Player multiple times. I have installed, installed again, unistalled, reinstalled, installed over, installed Unity Setup 2.6.1.....

I have downloaded UnityWebPlayer.exe from my son's Chaotic site and from NASA. Every time I run the program it says it has installed, but everytime a click a link to start it, it asks to install again.

I went to this site http://unity3d.com/webplayer/version/ and it says... Unity Plugin version: not installed Unity Engine version: not installed

I am not totally sure you should download our webplayer from any site other than ours. No-one has the rights to host our webplayer other than us, so please be careful if you download from unauthorised sites.

I would recommend the following:

If you are unable to play games based on Unity webplayer please follow these steps:

On PC:

a) Close all browsers.

b) Use Control Panel Add/Remove Programs to remove the Unity Web Player from your machine.

c) Reboot your machine.

d) Download from our website a new copy of the latest webplayer plugin (http://unity3d.com/webplayer/) and save the file to your desktop.

e) Close all browsers.

f) Run the webplayer installer.

g) Once the installer had finished, visit our website at the following address:

http://unity3d.com/gallery/demos/live-demos

On Mac:

a) Log onto your mac with a user account that has admin privileges.

b) Close all web browsers

c) Delete the file called:

/Library/Internet Plug-Ins/Unity Web Player.plugin

d) Empty the trash.

e) Reboot the Mac and log in with an admin account.

f) Visit:

http://unity3d.com/gallery/demos/live-demos

If the webplayer has installed correctly, and your machine is capable of playing Unity content, then you should see our demo running in your browser. If you can see our demo then other games should run also. If you do not see our demo running, please tell us in as much detail as possible what happens at each of the steps above.

You should contact support@unity3d.com about this.

I am having this same issue with playing Kings Bounty Legions on Facebook. It was working fine and then all of a sudden when I log into the game it’s asking me to install Unity Web Player. It already was installed and working fine. I have followed every suggestion I can find (about uninstalling, rebooting, reinstalling etc) and nothing is working. I am running Windows 7 with 64 bit, and using Chrome as my browser. It has not been a problem accessing this game in the past and I am at a loss to why it stopped working. Any suggestions please?


*UPDATE

Ok, finally found what was stopping Unity Player from working on my computer. I am on Windows 7 and using Google Chrome as my browser.

Open a browser and type in the address bar: chrome://plugins/

find the Unity Player in the list and make sure it is ‘enabled’. Mine was disabled for some reason. Once I enabled it, it is working perfectly now.

Hope this helps someone else out there with this same problem!

If the webplayer fails to load (Windows XP and Pro).

Go to run
type
services.msc

Find Terminal Services and set it to Automatic, and then Click start services if it isn’t started.

Not sure why it’s turned off for some people, but there’s probably a similar answer for other versions of Windows.

It worked for me!
I did the Steps word by word, as described above by Graham Dunnett.
I use Mozilla Firefox and this is what I did:

  1. I opened the Plugins Panel and Clicked the blue word “More” on the Unity Player plugin.
  2. Next I choose the “ALWAYS ACTIVATE” from the drop-down list
  3. and finaly I went to the the Unity’s live-demos webpage
    (http://unity3d.com/showcase/live-demos#mothhead),
    !I Refreshed the Page, I choose the second video (AngryBots) and it started Loading.

Now the Firefox Plugin does not show errors anymore :slight_smile:

For some reasons Only the first demo (Mothhead) does Not work.
The other demos works just fine.
I hope that helps other Firefox users. :slight_smile: