How make a texture non-repeating (non-tiled)?

Hello all. I’m new to Unity. I’ve successfully imported a blender model. The blender model had both a regular material, and a material with a UV mapped texture. I set that texture to not repeat, by setting the Extension option to Clip in the texture panel.

However, on importing the model into Unity, the texture image was missing. I added it manually, but now I can’t find any way to have the texture not tile. This is not a tile texture - I just need it once on the object. Is there a way to do this that I’m missing?

On the Texture Import settings, near the bottom of the standard controls, is Wrap Mode. It defaults to tile, set it to Clamp.

Failing this, there might be something wrong with your UVs coming out of Blender (UV’s might be on the wrong channel, etc).