How many terrain lightmaps are generated with beast?

When baking my outdoor scene, the shadows on the meshes are crisp (30 texels pwu) but the shadows on the terrain are hardly noticeable. What can cause this other than the lighting washing them out? Also, I can only get Beast to generate one lightmap for the terrain object. Is there a way to set more than one?

Try setting the lightmap resolution higher for your terrain. I'm pretty sure it's currently not possible to assign more than one lightmap, though. I know that many people are struggling with this, because you need a pretty huge texture if you want nice crisp shadows on your terrain, which will obviously have an impact on performance.

Thanks, but setting it all the way to 4096 only gives a relative texel count of 5 (compared to 30 on the mesh objects).