How to achieve this type of Occlusion?

Hi, so I downloaded the VR assets and I looked at the Maze scene, I tried to copy the occlusion from the maze but I haven’t been able to, I copied every setting, material, shader, etc. and I still am not able to reproduce the same effect.

on the right there’s the original maze, as you can see, even though it has the same settings, lighting, occlussion, materials, etc it doesn’t look the same.

The only difference between the default Maze scene and your scene is the lighting settings.

The maze scene uses non-directional light, and a custom cubemap for reflections. It also uses gradients instead of lighting.

I wrote up a detailed post on all the specific settings but it was pending approval and is now lost. Just check all the settings in the lighting tab.

If I’m understanding it correctly, the maze on the right has a slight shadowing on it, while the new one on the left is flat white? That’s what you need to fix?

Window → Lighting, uncheck Auto and hit “Bake”. This will bake the lights in the scene for you, as well as create the shadow and ambient occlusion effects.

Make sure your other maze is marked Static.

The effect is called Ambient Occlusion. It doesn’t seem that their scene uses or bakes in Ambient Occlusion, it’s just how the lighting is configured in the scene.

In the Window → Lighting the VR maze sample has some changes from the default lighting setup.

Environment Lighting

  • Ambient Source = Gradient
  • Sky Color = RGBA(248, 248, 248, 255)
  • Equate Color = RGBA(227, 227, 227, 255)
  • Ground Color = RGBA(195, 195, 195, 255)
  • Reflection Source = Custom
  • Cubemap = MazeSkybox

Disable Baked GI (Unchecked)

General GI

  • Directional Mode = Non-Directional