How to avoid annoying baking in unity 5

I am getting quite irritated about how when i try to edit the terrain. That in always gets very laggy when i try to build the map. How do I avoid the baking without having pure black shadows. nor flickering.

P.S I dont use shadow baking i used dynamic shadows.

If you are not using it, disable Global Illumination. Window → Lighting → Scene and disable “Precomputed Realtime GI” and “Baked GI”, in other settings your should also disable “Continuous Baking”.

Necroposting for a good reason.
Like me, new users may get here so, on 2018.3 Window>Rendering>Light Settings then on Scene tab uncheck “Auto Generate”.
Hope it helps.

Year 2018, unity 5.1 used,
Problem: Baking not stopped even after turning off Real-time lighting and Mixed Lighting and Auto Generate Also Unchecked.
Solution: Just Changed the Compression from ‘Auto’ to ‘UnCompressed’.
Remarks: I dont know why that worked. But it worked. !!!