How to avoid or turn-off "Combined mesh (root scene)" feature.

Imagine an FBX import that has a few elements, let’s say the “floor of a room” and a couple of chairs.

Click on floor in the Hierarchy: in the Inspector, you will see the mesh “floor”.

NOW … click Play.

After you click play, the mesh changes to: “Combined mesh (root scene)”

(*) essentially, how can you “turn that off” ? I want it to stay as “floor” rather than changing to “Combined mess (root scene)” after pressing Play.

Thanks in advance for any info.

Sycla has perfectly answered this question … just turn off static batching or indeed just uncheck the static box on the item. Awesome.

That's static batching playing up there. Try turning off static batching in the player settings.

Just out of interest, why is this so important to you? If you pass everything around by reference anyway, shouldn't the name not matter at all?

I know that this is an old post, but I just want to add something crazy here. I had some objects in my game where physics were just not applying to them at all. When I added a Rigidbody, nothing would happen. When I added a script that added force, then this would not work either. I stumbled across this answer because I noticed that the objects that were affected turned to Combined Meshed. I turned off static batching and the objects now react as they should.

Just thought I’d add this in case anyone else had the same issue

Another tip that may help other’s with static batching:
I use CommandBuffer.DrawRenderer() to draw a MeshFilter’s sharedMesh, which is combined at runtime. Through FrameDebugger, I found CommandBuffer.DrawRenderer() draws an incorrect mesh. When I use subMeshIndex to iterate all submeshes, it turns out drawing the combined mesh.

When static batching Turned off, I get desired result.