How to bake shadows in unity3d free?

i’ve heard a new directional light feature which allows you to bakw shadows in unity free. i tried, and i didnt work. i selected the light and chose hardshadows and nothing happened. is there any way toget that fixed? i really want some shadows in my game.

Unity can only lightmap objects that do not move - ever. If this where not the case, you could end up with shadows from an object that is no longer there. To tell Unity you’re not gonna move an object, you mark it as “static”. Do the same with your lights (forget to tell, you will need a light, preferabilly a directional light). Keep in mind that lightmapping alone might not be enough: moving objects such as enemies, cars, the player character and any physics objects can not be lightmapped.

I assume you’ve already found the hidden-by-default lightmap window. Just start baking from there - depending on how fast you computer is, it might take a while. If it takes way too long (longer than 10 minutes), I’d recommend setting the quality to “low”, setting Ambient Occlusion to “0” and rendering at a smaller resolution (25 or 50 instead of 100). Once you’re happy with your settings, feel free to turn the quality back up and wait for Unity & Beast (the program that makes the lightmaps) to finish rendering.

As a side note, Unity Free also has real time shadow options. The directional light can have hard shadows in Unity Free.