How to color the (transparent) underside of a mesh

Hello, I believe this is a relatively simple question. I have a tent model that looks fine on the outside, but once you step inside of the tent, the entire underside of the tent is transparent and you can see out of it as if walls didn’t exist. I’m sure this question has been asked somewhere, but alas, I could not find it and asked here. Here’s what it looks like. Any help would be much appreciated! 125924-screen-shot-2018-10-10-at-33451-135pm.png

I should also probably add that I attempted to fix this problem in blender, but it looked non-transparent there. After exporting as fbx, it’s transparent.

So, this is basically how game engines work. It’s referred to as “backspace culling” if you want to look into it further. Only the triangles with front-facing normals are paid any attention. By extension, if you ever import a model and you have ‘missing’ faces, improperly set up normals are probably why. There are essentially two options to fix this.

  1. Model the inside of the tent. Probably the best looking and least troublesome option, but of course, it will require more time and effort to do.
  2. Enable backface culling within the shader. This is as simple as setting a flag. You can either write your own shader or find one, it is relatively easy to do especially with a shader graph tool (which I think is built in to unity now?) . While it’s easy and fast, the downside is that it’s essentially just ‘reversing’ the same face, because it technically is. So it will share whatever texture is present, and so on and so forth.

Hope that helps!