How to completely disable auto-recompiling everywhere (in favor of manually compiling them)

Question:

Is it possible for me to create a custom script that will fully disable auto refresh for other locations in Unity that triggers it (in my case, asset creation/deletion)?

Or is this a bug that can be fixed by the Unity team so that unchecking the setting fully disables it in all locations?


My problem:

Unchecking the Asset Pipeline → Auto Refresh setting doesn’t fully disable this "Reload Script Assemblies" behavoiur. In particular I found that even though this setting is disabled, it still happens for every new or removed Asset (i.e.; creating a script via Assets → Right click → Select CreateC# Script, or removing one via in Assets → Right click an asset → Select Delete). I’m not a fan of this Auto Refresh functionality (anywhere in Unity), it’s very disruptive and annoying to keep running into it with very minor changes.

In addition to the Auto Refresh setting, I have my General → Script Changes While Playing set to Recompile And Continue Playing, but I’m not currently playing when this refreshing happens so I know that isn’t what’s triggering this. Instead it feels like there’s other locations in Unity that should be respecting the Asset Pipeline → Auto Refresh setting but aren’t setup to respect that setting.

There’s lots of articles about how to disable auto refresh, but I haven’t found any that are specific to new or deleted assets (some links I’ve found listed below); they’re primarily for code updates to existing scripts, or when starting to play (or already playing).


A few links that are related to this issue

but aren’t similar enough to help me solve this problem:


My system info:

  • Unity version: 2021.3.3f1 Personal
  • OS: MacBook Pro macOS Catalina Version 10.15.7

(I posted this as a comment, but that’s not easy to see unless you expand comments, so posting as an answer as well)

Just found out this site is shutting down soon (June 23rd, 2022), I don’t think there’s much hope in getting a definitive answer to this question by then. I re-asked this in Stack Overflow here (unity - How to completely disable auto refresh everywhere (in favor of manually compiling them) - Game Development Stack Exchange) if you’re looking for answering this (or looking for an answer to this).