How to deal with an extra spine bone?

I’m trying to do some MoCap and import them into Unity. I have an extra spinal bone in the armature and Unity doesn’t like it. How do I fix this?

Do you not need that bone and want to keep your animation type as Humanoid? If so, in the Rig tab of the model’s import settings, hit “Configure…” under Avatar Definition and make sure none of the slots reference the stray bone.

If you do need that bone, then you have a rig that doesn’t fit the definition of a humanoid rig, and you have two options: change your Animation Type to Generic, or open your model in 3D modeling software like Blender and transfer the weights from one of the extra spine bones to a spine bone you plan to keep, then delete the extra bone.