How to debug "Invalid editor window UnityEditor.FallbackEditorWindow UnityEditor.EditorApplication"?

I get this message in console:

Invalid editor window UnityEditor.FallbackEditorWindow
UnityEditor.EditorApplicationLayout:FinalizePlaymodeLayout()

How can i debug this message?
ANSWERS
“Try resetting the editor windows to Factory settings.” (telecaster)

Any idea?

Hi
I got this error when I imported snap settings, but it can come from any editor extension that comes in conflict with other editor windows. Try resetting the editor windows to Factory settings. If you get something like "Failed to destroy editor windows: #3" you are getting closer. In my case the error went away after that. Hope this helps someone.

1 Like

I get this fairly frequently since upgrading to Unity 2019. I don’t like the default factory layout, so I’ve saved my own custom layout, which only contains standard Unity windows - Scene, Game, Hierarchy, Project, and Inspector. But whenever I see this error, the layout button appears blank. When I re-select my saved layout, I get the message “Failed to destroy editor windows: #2”, but my layout doesn’t appear to change. After clearing the errors, I’m OK again until next time - which can be an hour, a day, or a week later. I’ve seen no consistent pattern leading up to the error, but it often first appears when I select Play mode in the editor after making changes to my scene or assets.

I’ve made no custom editor windows of my own, but my suspicion is that it’s caused by one of the third-party assets I use, which sometimes do use them. So it could be that one or more assets - such as Gaia, Vegetation Studio, or one of my water assets - has a custom editor window that Unity 2019 doesn’t like, for its own secret reason. That’s the really aggravating thing though - it never shares that reason, or gives any clues in the error messages to help pin down the culprit. If anyone has found any connections to specific third-party assets, please let us know, so we can file bug reports with their developers.

2 Likes

@Liderangel filed a bug report on this recently. You can vote for it at: Issue ID: 1287233. If the link doesn’t work, search with “Scene/Game View” category and “2019.4” version.

4 Likes

This error still shows on 2019.4.13f1

1 Like

I just closed the window and re-opened it.

1 Like

The bugs say “fixed” but you still have to delete your data to be able to remove the error (and to be able to use the fullscreen mode of Unity!). That’s not a great “fix”.

What do you mean by “delete your data”?
Do I need to “Reimport All”?

For me it only works when you "reset to factory settings" which deletes all your saved layouts (if you do a lot of work with Unity, you could have quite a lot of these, for special cases, different projects, etc)

1 Like

There were no "revert factory settings" in 2020.2.0f1 I press "reset all layouts" and a lot of window pops up. I presume my antivirus.

6645565--758866--Reset.jpg

EDIT: Yes was my antivirus

Invalid editor window UnityEditor.FallbackEditorWindow
UnityEditor.GenericMenu:CatchMenu (object,string[ ],int)

I get a similar error after selecting save as scene template. It doesn't seem to be restricting me from doing anything (as far as I know, I'm still new). May not be the same as ya'll but figured I'd throw it in lol.

For me, Layout → Reset All Layouts fixed it. I could not Maximize On Play until I did this.

1 Like

Hello Smasher, well come to this forum. I’m a user like you. To debug issues sometimes what I do is to make a copy of my Project. Then I open the copy (using the Hub). I start taking out assets from my hierarchy by deleting them. usually is one game object that triggers the problem when I press play. From there I start taking out the components to understand what component is triggering the error.

When is an editor problem, the bug and related error message in the console is trigger also in an empty project. So I start deleting the Project content from the Asset folder. At some point, the error is not triggered so some deleted content was the cause of the problem. I often make a copy of the project when trying to isolate the script in this way. Takes time but often works.

At that point is simply to make a bug report with only the isolates scripts and relative game object.

Same here with 2021.1.16f1

When I open my project and play it (maximize on play enabled) then it works.
When I click on my Terrain Gameobject in the Hierarchy then it don't play and I get this Error.
When I reset my Layout then it works again, even when I select my Terrain GameObject again.
When I close my project and reopen it, then I can start it. When I click on my Terrain then same Error. After Layout reset it works again until next reloading of the project.

Without "maximize on play" it works always. I have saved my layout and when I load my layout then it works again until next reopening the project.

very misterious bug!

For anyone who has this issue, you can just switch from one Layout to another. That would get rid of it temporarily. No need to reset all layouts.

1 Like

currently I have solved it with reloading my saved layout. But the bug is still present after reopening the project.

Invalid editor window of type: UnityEditor.CurveEditorWindow, title: Curve
UnityEditor.EditorApplicationLayout:FinalizePlaymodeLayout ()
In Unity 2021.3.1.f.1 LTS

_> HELP...!!!!

This bug happens to me every time I open a curve window. No matter how I handle it, this error has to appear eventually.
I learnt to ignore it, but it's ridiculous that such a small issue hasn't been addressed for so long