How to Disable auto-completion in Visual studio?

When I type

public void Initialize

the second I put my first bracket, my line is changed to

public void OnServerInitialized() {

    }
(

I have disabled Intellisense for C# in options. I assume this is Unity tools for VS messing with my code, where can I turn this off?

There are two ways how to avoid this:

  • First simply press “ESC” when the autocompletion window appears. It has be be pressed before you type your opening “(”. Another way is to press “HOME” and “END” which will also close the suggestion window. Pressing “RIGHT” and “LEFT” arrow usually also works.
  • Second you can disable the autocompletion in the VS Tools settings. However keep in mind that any changes to this setting (enable / disable) requires a restart of Visual Studio to take effect.

Press ESC here:
91397-vs-autocomplete.png

Disable the feature here: