How to disable ScrollView dragging

I have a scrollview that scrolls when I drag and when I use the scrollbar, but I want to disable dragging the scrollview. How do I do that?

To disable dragging, set Vertical & Horizontal Scroll to false, then it can only be controlled by a scrollbar.

I think I just found the answer.
In the inspector for the ScrollRect Monobehavior, if you remove the reference to the Viewport there (set it to none), it appears that it solves the problem without causing any other issues. (Probably that’s the only use for this reference, since the Content is the one manipulated by the scrolling)

In the ScrollRect script inspector of the ScrollView object, unclick the Horizontal checkbox directly below Content. This prevents dragging horizontally. Likewise the Vertical checkbox controls vertically. The scroll view can only be scrolled programmatically after unchecking.

In the ScrollView object, set the movement Type from Elastic to Clamped