How to disable texture wrapping caused by compression?

When I choose Automatic compression (i.e. RGB compressed PVRTC 4bit on iOS) then I can see artifacts in my texture - it is being wrapped, even when texture wrapping mode is set to Clamp.

Source:

29709-tex_b2.png

Result (you can see brown line on the left even and it shouldn’t be there). The screenshot is taken from inspector preview.

29710-wrapped.png

When I disable compression the artifacts disappear, but of course I want to have the compression. Is there a way to disable that wrapping and keep good compression?

Generally speaking it is not possible to control that.

First, it is possible to set compression Quality to best. That reduces amount of artefacts.

Second option is add extra line of pixels on each side, although that’s PITA…

PNG file format is a compressed format like GIF and JPG. As you may know, JPG is a lossy compression. GIF is lossless but it’s old. PNG is the new GIF. Supports many features and compressed lossless.

If you choose to compress in unity import settings, actually you are converting it to JPG like format which is lossy. You can keep this import setting as Truecolor and it still will be compressed because your file format is PNG. (I’m not 100% sure if unity keeps the PNG format if we choose “truecolor” but if it does, it’s compressed)