How to disableTerrain Collider but keep the Tree Colliders?

Hello, I have a terrain in my level which I’ve painted trees on. I have drawing of the terrain itself disabled because I only wanted the trees visible, as I’m using a mesh for the ground in my level instead.

I tried disabling the Terrain Collider in the terrain settings but this also disables the Tree Collider, which I wanted to keep. Is there a way to have no collision for the terrain but keep the collision for the trees?

Thanks for reading!

Maybe this will help?