How to downgrade from Unity 5.2 to 5.1?

So my team told me to download Unity 5 but they didn’t specify which version, 5.1 or 5.2.

I decided to go with 5.2. Now I oppened the project in 5.2 and some classes work in 5.1 but not in 5.2. This means I need to remove 5.2 and install Unity 5.1.

Is there much easier way to do this or I have to go trough the painful process of downloading 1.5GB installer? Then remove 5.2 and install 5.1.

To be more specific I get these errors:

Assets/SpaceD Hud for UGUI/Scripts/Effects/Gradient.cs(8,22): error CS0619: `UnityEngine.UI.BaseVertexEffect' is obsolete: `Use BaseMeshEffect instead'

Svn Tools: Unhandled exception in the SVN Command Line. Please report this as a bug to the developer
Error: svn: E155036: Please see the 'svn upgrade' command
svn: E155036: The working copy at 'D:\game\Unity'
is too old (format 29) to work with client version '1.9.2-SlikSvn (SlikSvn/1.9.2)' (expects format 31). You need to upgrade the working copy first.

You have to go and download the old installer and delete the new one this is the most safest and fastest method so you and your team wont get any problems later :wink: