How to enable Anti Aliasing on Android devices

Hi guys. The problem I am facing is that at the intersection of 2 planes there is like a staricase of pixels. Normally AA would fix this, however enabling AA in the quality setting didn’t fix this issue. The strange this is that when I run the game in the editor, AA is enabled. The devices I tested the game on are HTC One S and Nexus 7(2012). Here is a screenshot showing the problem: Notion – The all-in-one workspace for your notes, tasks, wikis, and databases.

Deos anyone know a solution to this problem?

An update on this issue. Unity provided this response:

Our developer has investigated this issue and came to the following conclusion:

“This issue is device specific. That particular device/gpu mali 400 doesn’t support anti aliasing when using a 24bit frame buffer. And as of Unity 4.3 we use a non-alpha enabled frame buffer by default since the android hw compositor has problems handling direct frame buffers with alpha.”

So this issue will not be fixed. *

*emphasis mine.

This is a very disappointing outcome and a significant show stopper for using Unity for Android development.

I think Unity should not ignore this issue and look for a better solution than ‘no AA’. No AA maybe acceptable on high density screens, it is absolutely necessary for lower density screens (think tablets). My current game looks beautiful with AA and absolutely awful without.

If this issue effects you, please be vocal to Unity as we need to raise the priority on this issue.