How to enable unity remote 5 to work with android device

im using unity remote 5 to connect to my laptop the version of the app of unity im using is 5.4 have tried everything but its not working any advice would be good,have already tried the sdk things but have not had luck

Not sure if this will help, but I also had this problem and I made it work following these steps:

  • In Unity, leave enabled the option at “Unity Remote Editor Settings> Device> Any Android Device”
  • Close Unity.
  • Open Unity Remote App on your Android device.
  • Connect your device to your computer.
  • Open Unity again.

It looks like it’s working to me!

I hope that helps.

(I’m using Mac)

If anyone has tried the suggestions, and failed to get the Unity Remote working, do this:

Setup in Unity: “Unity Remote Editor Settings> Device> Any Android Device”


  1. Open a command window.
  2. Navigate to your Android ADB folder. (For Windows Users, C:\Users[UserName]\AppData\Local\Android\sdk\platform-tools)
  3. Kill the adb server with the following command: adb kill-server
  4. Restart the adb server: adb start-server
  5. Open Unity Remote on your device.
  6. Press play.

Repeat whenever you encounter this issue.

Yeah, i wasn’t getting it working at all, until i closed unity, after configure the Editor Settings, connected the usb cable in the motherboard entries (not the front panel ones), waited the smartphone connect, inicialized unity again, pressed play and voila!

In my case it works only when the device is connected to some USB on a motherboard (only first 4 USB’s). Doesn’t work on USB on the front panel and PCIE USB extension card.

For Xiaomi phone Users,
Make sure to select PTP option(Transfer photos) by tapping on ‘charging only’ when you connect to pc via USB.

If people are still having trouble with this I’ve finally been able to get some stubborn android devices to work with the Unity Remote by disabling and re-enabling developer options:

  1. Close Unity

  2. Unplug device

  3. Disable Developer Options on your phone if they are on

  4. Enable Developer Options (Typically you just need to go to “About Phone” in settings and click "Build Number 7 Times)

  5. In Developer Options, enable “USB Debugging”

  6. Plug your phone back into the PC

  7. Start Unity

  8. Make sure Editor is set to allow any Android Device

Not sure why this works as I was under the impression you didn’t need to have Dev Options on to use the remote, but it works for me.

Hope this helps someone!

For anyone experiencing this problem with an LG Smartphone (LG G5 for me) :

  • Connect your device via usb
  • Close Unity
  • Grab the universal drivers by LG here
  • Do the adb kill-server and restart adb as described above
  • Launch Unity, it should work now

@Mactroz idea worked for me. In my case it was LG V30+ and Unity 2019.1.9f1 and Unity Remote 5.

  1. Install LG Universal Mobile drivers from this page
  2. Connect the phone. Make sure the connection works (you can open the phone via Explorer; in case you can’t use another cable). Close Unity on PC and Unity Remote on the phone.
  3. Device Management - Portable Devices - find your phone name (not model - the name you gave it when setting up for the first time). Remove the device and check the remove drivers flag. Pull it out of USB immediately.
  4. Activate Developer mode on the phone, turn on USB debugging, choose MTP mode as USB connection mode.
  5. Kill adb on PC. In my case it was Powershell C:\Program Files\Unity\Hub\Editor\2019.1.9f1\Editor\Data\PlaybackEngines\AndroidPlayer\SDK\platform-tools> .\adb kill-server
  6. Turn adb back on: .\adb start-server
  7. Plug the phone in, wait for device successfully installed confirmation.
  8. Make sure adb sees the phone: .\adb devices
  9. Start Unity, choose Project Settings → Editor → Device - Any Android device (or phone name, if you’re lucky).
  10. Start Unity Remote on the phone, press Play in Unity. The game will start both on PC and on the phone.

Check out this guide on how to get unity remote 5 working if it’s not working for you.

Go and check out this video 1 Link Unity and Unity remote Part-1 - YouTube , 2 Link Unity and Unity remote Part-2 - YouTube

Even if you don’t have android device,
you can use Genymotion – Free Android Emulator (For Personal Use),
its run my unity APK’s so far.

In my case I just had to switch the USB Mode of my phone from “transferring Data” to “transferring pictures” (second option from top)

I got this alert:
“Set-up Android SDK path to make Android remote work”. That must be set on Unity/Edit/Preferences/External Tools

I also had to install Google USB Driver on the Android SDK manager/SDK Tools

The last missing step was:
Unity/Edit/Project Settings/Editor/Unity Remote Device set to ‘Any Android Device’

I hope that helps

I was helped only by manual installing of adb driver. Instruction (in Russian)

  1. Close Unity
  2. Make sure you have “Developer Settings” on on your phone. (Tutorials on youtube about it) and enable ‘USB Debugging’ & Photo Transfer / Camera PTP (Peer to Peer).
  3. Make sure that the USB Cable is connected to the motherboard
  4. Open Unity Remote 5
  5. Open Unity & Run the game, wait a few seconds and it should start.

I tried all of the options above and nothing. I have a Samsung Galaxy S7, the solution was this:

-Make sure to have Developer Options and USB Debugging enabled in the Phone.

-My type of connection Phone to Computer was MTP (it can be set in the Developer Options of the Phone).

-In Control Panel-Device Manager (or Management, not sure cause I have it in Spanish).

-Looked for the device driver, in my case was under Portable Devices, then I unistalled it and immediatly unplugged the phone (because in some cases Windows tries to install again the drivers and we don’t want that).

-Installed Samsung Kies 3.

-Plugged the phone and I saw it installing something new called Android ADB Interface.

-After the install my phone asked me if I’d like to connect with USB Debugging, I chose Yes.

-Opened Unity and hit Play.

*Note: My phone is never displayed in Editor Settings-Unity Remote-Device in Unity, it still displays “Any Android Device”.

for xiami users also check this , it might be useful :

Hello Everyone!

I am astonished by the fact that no one mentioned the following solution.

Whatever brand of android smartphone manufactuer you are utilising, one has to enable developer mode on the device and enable usb-debugging afterwards.

Open the settings on your android device and navigate to OS version. Tap that entry a couple of times and developer mode is enabled. Afterwards just use the searchbar within the settings to find the developer settings and enable usb-debugging. On your first connection between smartphone and pc a promt pops up, asking for RSA fingerprint acceptance. It is important that you accept that dialogue, otherwise adb is simply not permitted to do the neccesarry api calls.

After spending a day trying to make this work on my Mac this is the only tutorial that proved valuable (will probably work for Windows too) :

The key step that was missing was to switch to Android build and download a Unity add-on for Android which was probably a requirement but mentioned nowhere in the official docs.