How to find out which SDKs are supported?

We have a school project to create an android application. I’ve never created an Android application before so I’m very new to this.
The only requirements were that the final .apk file can be run on SDK version 7.1.1. I noticed that in the Project Settings → Player I can select the minimum API level and target API level. I’ve currently set these to the default values: minimal to 4.1 (API level 16) and maximum to automatic (highest installed).
The way I see this it means that 7.1.1 should be supported but when I tried to build the application it said “Required API level 26” which to my knowledge is SDK version 8.0. Does this matter and mean that the supported versions will only reach from 8.0 to the latest or continue to reach from 4.1?

So, I did a little more research and found out how to view the minimum sdk version required and as it showed API level 16, meaning the app is supported from 4.1 and later. I even tested it on an emulator with version 7.1.1 and it did work there.