How to fix: !CreateDirectoryRecursive(fullpath)

I just installed Unity 5 on my PC (windows 8.1 x64) and when I try and create a new project (both 2d and 3d) I get a Fatal Error. The error says: “!CreateDirectoryRecursive(fullpath)”. Does anyone know what this is and how to fix it. I installed it on my mac just to see if I would get the same error, I didn’t.


System Specs:

  • Operating System: Windows 8.1 x64
  • Processor: Intel(R) Core™ i5-2450M CPU @ 2.50GHz, 2501 Mhz, 2 Cores, 4 Logical Processors
    Other information is in the attached text file (I recommend opening it with notepad++)
  1. Go to Preferences
  2. Select GI Cache tab
  3. Enable and Set custom cache location

Honestly? I don’t think Unity support has an answer here. If you’ve uninstalled the program, cleared your registry, then reinstalled, it, and it still doesn’t work, I haven’t seen a single plan B from them on any forum or bug support. There was a guy who claimed resetting his computer (after backing his data up of course) worked, but that seems pretty extreme. There was another who said that loading Unity 5.2.3 (I think) allowed it to work.

Even the fix suggested here fix doesn’t work because most people who get that error can’t enter Unity at all.

If anyone or Unity support does have an answer though, I would really like to hear it, because this is a pretty big problem for me.


Try running as administrator, seemed to work in Windows.

  • Andreas


I had this problème.It’s window’s registry problem, and the only way it’s to uninstall EVERYTHING and use a registry cleaner (like ccleaner) or remove from the Windows Registry the Entry HKEY_CURRENT_USER\SOFTWARE\Unity Technologies.

Good luck !