How to fix flicker with VideoPlayer/Skybox/XR setup

I’m trying to get video playing in VR following the instructions in the docs

I’ve done nothing but follow the directions in the docs. I’m using an Oculus Rift. Both inside (in VR) and (on the desktop) it flickers.

The video I used is [here (2gig)](https://www.dropbox.com/s/a73c9qbhenqpbi8/kramer_knives_safe_4k_h265_ambixsoa_180_3D.mkv?dl=0) from [this article](http://echeng.com/articles/peak-quality-3d-180-oculus/). I ran it through handbrake on the Very Fast 1080p preset, the result is 271meg 1920x1080 video file.

My project is here including a 10s segment of the video the creator was nice enough to license CC-BY-NC.

You should be able to load it up, I’m using Unity 2019.3.5f1, and then open the samplescene. You might need to click on the main camera and in the Video Player component set the URL to the video

Okay so first off this seems to be a timing/sync issue. A smaller video does not flicker. Of course a large video should not flicker either so somewhere in the uinty pipeline a sync or wait is missing

Otherwise digging through the settings I turned of HDR in Project Settings->Graphics under Tier Settings. I unchecked “Use Defaults” for each of the 3 tiers and then unchecked “Use HDR” in each of the 3 tiers (don’t need HDR for this project)

The flicker seems to have gone away. I suspect I’m just getting lucky in that rendering non-HDR takes less time so the sync bug is not manifesting but I’ll cross my fingers.

update

Maybe I’m doing something wrong but I found the VideoPlayer’s performance to be too slow and it sitll flickered. I ended up using AVPro Video