How to fix mono.dll Access Violation

I’ve been using Unity 4.0.1 for the past month with no problems. On 3/8/2013 Unity would crash during the splash screen, before the prompt to open a new project. In the error log it said, “mono.dll caused an Access Violation (0xc0000005).” Unity will crash on startup every time I try to open it with the same error in the log. Here are the fixes I’ve tried so far:

Shut down computer and restarted it - Crashed

Hold Alt during splash screen - Crashed

Uninstalled Unity 4.0.1 and downloaded/reinstalled Unity 4.0.1 - Crashed

Downloaded/Installed Unity 4.0 - Crashed

Downloaded/Installed Unity 3.5.7 - Worked! However I need features in 4.0 or greater on the project I’m working on.

Created a DEP exception for Unity 4.0.1, restarted computer - Crashed

I found any version of Unity 3 works correctly, but I need 4.0 for the project I’m working on. I’m confused since Unity 4.0.1 was working less than a week ago and now it won’t even load up. If anyone has anymore ideas please let me know. Thanks!

I guess I answered my own question just doing research. I found this question on here:

Access Violation at mono.dll

Looks like he had the same problem as me, and his “solution” worked. I actually deleted my SVN repository and redownloaded it. Unity 4.0.1 is working just fine now on my computer.