How to fix pixelated shadows?

I tried all of the other solutions I could find but none have made a difference.
Im using a point light with realtime lighting.

You will need increase your shadow resolution. Your project’s quality settings will also affect the shadow resolution .i.e. Low quality will have lower resolution shadows by default vs what you have for High Quality.

How you do this is also affected by which render pipeline you use as the built in/URP/HDRP all have different means of setting shadow map quality.