How to fix Unity 5 "not responding" (Windows 10)

I recently upgraded to Windows 10 and I’ve been checking my programs to see which ones are working. When I try to open Unity, this shows up:

I saw questions with answers saying to hold Alt immediately after launching Unity so it will open a new project but this doesn’t work for me.

I also saw a thread with the exact same problem as mine (also upgrading to Windows 10) but I tried all the solutions provided, still nothing worked.

It seems that they read a crash dump file created when Unity crashes and from there they can determine the cause of the crash. Can someone tell me how to read the dump file and determine the cause ? Or if it’s not easy to explain , can someone determine it for me?

Here’s the dmp file.

Thank you!

Looks like you have Lavasoft WebCompanion installed.

This is a currently known problem for 5.1, that 64 bit Unity is not functioning with Lavasoft or other web proxies. We’re investigation solutions.

In the meantime, either uninstall Lavasoft or switch to the 32 bit Unity install.

I had the same issue with 64-bit Unity 5.1.2f1 and 5.1.3f1 under Windows 10 Pro.

The first run after fresh Unity installation under Windows 10 was actually okay as I logged in my account and activated the Pro version with my key without any problem. But the issue started to occur since the next attempt to open Unity editor.

The issue somehow was fixed when I tried to open Unity editor while keeping my VPN (Astrill) connection on. So I guess it may have something to do with Unity’s certain web calls.

Please try using some proxy or VPN if you still have this issue.

If you have Lavasoft Ad-Aware or Webcompanion installed.
Delete the file C:\Windows\System32\LavasoftTcpService64.dll
I had problems deleting this file since Windows was denying me access. I fixed this by opening Command Prompt (cmd) and type: DEL /F /Q /A C:\Windows\System32\LavasoftTcpService64.dll , alternatively just type “DEL /F /Q /A” then drag the file with your mouse into the command prompt window and press enter.
This worked for me atleast, hope i can help people with the same problem :slight_smile: