How to I get my gameObjects to not spawn far away

When I add a gameObjects in the hierarchy it just keeps being added far away, which is annoying since earlier it just normally just got added right in front of me.

I should probabbly add that this problem only accured when I opened the project after not entering safe mode. Which I know was very dumb of me but I need help

You can try checking Edit → Preferences → Scene View → Create Objects at Origin.