How to ignore the "Mesh doesn't have albedo UVs." error message?

I have a editor-script that generates a bunch of meshes that represent a terrain (or race track). It works well and creates nicely very tesselated terrain…

…but the problem is that I get two editor-only errors for each mesh.

First one is:

“Mesh doesn’t have albedo UVs. Please create them in your modelling package.”

and the other one is:

"Mesh doesn’t have UVs suitable for lightmapping. Consider enabling “Generate Lightmap UVs” in the model importer."

I do not need either of the UV channels as I calculate all UVs on the fly in the vertex shader. I would not want to add them, because they are not necessary in this case and just waste memory and gpu bandwidth in this case.

So is there a possibility to make the editor to ignore these errors?

Figured out the reason for the error:

Someone in my team did enable GI baking in the scene, and GI and lightmaps need UV coordinates. As none of our shaders require lightmaps/GI, I just disabled the GI baking.

So there’s no need to have UV:s in Unity if shaders don’t require them

I fixed this by making the object non-Static. It worked in my case.