How to Import 3ds max or sketch-up Models,maximo models properly to Unity3d.

When ever i try to Import my created models to unity its looks different after importing how to fix it.
Its a big problem to make a game. model look inside out. can any one tell Me how to fix it please help me. I am 16 year old boy, i love to play games,but more than playing games ,i love to devlope a game.
for making games i learn 3ds,sketchup,blender.now i am stuck in that problem.please help me to get solution.,

Reverse the normals or recalculate them. If you scale or mirror a mesh it can sometimes end up with the inside out. If 3ds Max lets you see backfaces then you won’t notice until you import to Unity.

unity does not support double sided objects so what may appear to be correct in your 3D app ( because set to double sided) can be wrong in Unity. I use Maya so don’t know how to use the 3D apps you mentioned…but in Maya it’s a simple checkbox on the rendering tab called “double sided” and I uncheck that. Also , delete non deformer history ( another maya thing) because FBX files with history( an invisible account of all the manipulations made to the object) can mess up the model in Unity. Coming from Mixamo …they are FBX files and should import into Unity just as you see them if it is a mesh you first uploaded to Mixamo to rig or apply animations. But if you mean a model from their library I would first bring it into a 3D app to check out if it is double sided

Hi,

I’m new at Unity too. I came across this guide which helped me import .skp files:

Specifically, the step:

  • Make sure to include “Triangulate all faces”, “export two-sided faces”, and “export texture maps”

Prior to that, I had walls that were visible from one side, disappearing objects.

Hope it helps.