How to importe 3ds max model with working texture?

Hello everyone, I’m having trouble with the textures of my models on 3ds Max; I can see it well textured on 3ds Max, but not on Unity, I suppose is just something that I’m missing but I can’t find it :frowning: please can somebody help me on this one?

This is the screenshot from 3ds Max:

And this is the one on Unity

The textures are all stretched out despite I’ve tried importing as .FBX or importing the .3ds file to my asset folder, but it’s the same. I have collapsed all my geometry and converted into editable meshes and even left the UVW unwrap but it’s the same.

I’ve read the manual’s section on importing .FBX and watched many youtube videos and things are just not working for me (it looks really simple to import sutff into Unity, so I’m guessing I’m doing something terribly wrong but can’t figure it out.

I’m usind 3ds Max 2011 and Unity Version 5.3.1f1

Sorry if it’s already been answered this error or is a duplicated post. I just can’t find a solution :frowning:

Thanks everybody.

Hi Fredex8,

Yes, you’re right indeed, is the tiling! knowing what the problem is, it’s easier to find the solution:

Had to set ‘Wrap Mode’ from ‘Clamp’ to ‘Repeat’; I couldn’t have done this before because after importing the texture files to Unity, the default ‘Texture Type’ was set to 'Sprite (2D and UI) and the Wrap Mode option was not showing up. (In case somebody runs the same problem on not finding Wrap Mode).

Thanks @Fredex8 & @meat5000 for stopping by :slight_smile: I knew that asking somebody was faster and easier to just try and fix the problem alone.

I think that this answer is solved, although I was wondering why my textures were imported as Sprite rather than Texture; maybe some setting on the exporting options / 3ds max format saving process??

Regards! :slight_smile: