how to make unity game to run on any version of android?

I make a unity game as like space shooter game. I want to run this game on any version of android device. When I build the game for android, I choose minimum api level to Android 2.3.3 Gingerbread (API Level 10) from player setting. After it built, it don’t work on Android version 2.3.3. But it work on android version 4.4.4. This is the problem for me. I want this game to work on lower version of android device. But I don’t know how to fix it? So, please give me a piece of advice.