How to make WebGL build to use Dedicated GPU

Hey can anyone share how to make unity webgl build to use dedicated GPU instead of default integrated GPU?
I tried some ways , but not working. Some of the ways like adding powerPreference in config etc..... But none of them worked :(

You probably already ran into this or similar articles?
https://alteredqualia.com/texts/optimus/

The issue is likely graphics driver / notebook model or vendor / browser specific and not limited to Unity apps. I'd try a graphics driver update if the browser settings don't take effect.

The powerPreference in the WebGL Player Settings is the mechanism we have to tell the browser to prefer either the dedicated GPU or the integrated GPU. It's ultimately up to the browser to decide which it wants to give us.

2 Likes


Already went through it. Still not working. I don't want to make users to do the settings change in nvidia control panel from their end. thanks for answer :)


Thanks for confirmation :)