How to play 5.1 surround sound with 6 WAV files in scene

I am using Unity 2018.2.1f1. My project Audio is set to 5.1 Surround. I have 6 mono WAV files, one for each channel (L/R/C/LFE/Ls/Rs). I have placed each sound in the corner 10 units around my main camera, which never moves. I have attached all sounds to an AudioSource. These are all connected to an AudioMixerGroup under the main AudioMixer.

When I play the audio in preview mode, regardless of which channels I play, the mono sound can be heard in ALL speakers (and barely in the rear). I have set Spatial Blend for all AudioSources to 0 (2D), Reverb Zone Mix to 0, Priority to 0. Min Distance is 1, Max Distance is 2 (for testing). Regardless of any settings, I hear every sound in my front 3 speakers, even when I only play Ls channel (Left Rear). When I play the sound back, the AudioMixer shows 6 channels but only ever shows green volume bars on the first 2 channels. Interestingly, when I move the sounds around in the scene, it doesn’t matter how far away they are from the camera, the volume remains the same.


I have tested with other stereo sounds (set Spatial Blend to 1) which I move around the camera and after distance of ~8 I can’t hear them anymore, therefore it’s something to do with using 6 mono sounds.

I have tested 2 different 5.1 sound cards (Behringer FCA610 and LogiLink USB 7.1) and both exhibit the same behaviour. My Teufel Concept 5.1 system says it’s currently in “Pro Logic II” mode and it’s wired with SP/DIF optical cable to the Teufel. I can play movies in 5.1 using e.g. VLC just fine. I can also get 3D sound to work if I just play a stereo file and move it around the scene, although the rear speakers are always extremely quiet.

I have read everything I can about audio and tried the forums but there is nothing which seems relevant to my case, but I am willing to try anything at this point.

Is there anything else I can investigate or did I perhaps miss some setting? Thanks for any advice!

Did you find any solution to your problem? Having a similar problem…

you need a 5.1 audio file, not 6 mono files.