How to publish for iOS in snow leopard (10.6) ?

According to unity doc: Unity Requirements
The minimum version of Mac OSX is 10.6 (snow leopard).

I have purchase the iOS extension of Unity, and the Developer program fee.

But, I’m stuck to the step of downloading IOS6 SDK.

AFAK, the only way to have it is from XCode4 in App Store…
I can’t have it, it requires 10.7 version of MacOS !

Did you think I missed something here ? Since IOS6 release does publishing restricted to Lion ?

Unity the editor is compatible with Snow Leopard. You can create Xcode projects using Unity on Snow Leopard. What you are referring to is possibly an Apple restriction on Xcode and iOS 6.0 SDK.