How to re-anable resolution pop-up when running Unity standalone?

Before Unity 2019.3 when I created a standalone .exe, when you ran it you would get This Pop-up

After updating to unity 2019.3 I no longer get that popup when creating standalone .exe’s. I can’t find anything in the build/player settings regarding this, how do I re-enable it?

In some earlier versions of Unity, it was said to be deprecated and will be removed. Therefore, you will have to find some other way to change those settings :frowning:

I see 3 viable solutions:

  • First, don’t upgrade your project to the latest Unity version but stick with the one where it still works. This is the easiest solution if your game is already almost finished. However it makes further updates more difficult if you want / need to upgrade at some point
  • Second, if you want a similar dialog before the game actually starts you can create your own launcher application in plain C#. So you can recreate the essential settings there. So the user would start your launcher and the launcher would start your actual game and either pass the settings on (command line parameters) or it just writes a config file which your game will read at startup
  • Third, just create the settings menu inside Unity in the first scene. This would be the second easiest solution but of course the user has to wait until Unity has gone through the splash screen(s).

Note that there are some things that are difficult / impossible to change through your own settings dialog. The biggest issue is the old input manager since it doesn’t provide any way to change the key bindings through scripting. If that’s what you need your only option at the moment is to stick with your previous Unity version where the dialog still works. Though in the long run it’s generally better to switch to the new input system.