How to run the exported game on ubuntu

I am having a problem running the exported game on ubuntu linux.
I am getting this message:
Could not display “/media/*****/682A-88E8/Game”.
There is no application installed for executable files. Do you want to search for an application to open this file?

What should i do to make it work?

right click on executable properties->permission->check “allow executing file…” and try again, some error might still occur if missing dependencies so i suggest to run it in the terminal so you can see it

in terminal type: chmod +x nameOfGame.x86

then, in the same folder where you have your game data, in your terminal run: ./nameOfGame.x86

Make sure both of the files (the exe and the data folder) are on the home drive not a usb. the right click the exe and tick “executable” now the game should run when you click it.

Thanks for your help, but… I’ve found an easy solution in the meantime :slight_smile:
I asked a friend who had a similar problem with deploying a linux app for many customers, here is the way he used to do :

  1. download attached here, unpack and install it

  2. in terminal type : getlibs pathToYourUnityAppfile

  3. wait for the downloading of everything

  4. reboot

done ! you can run your linux unity exe by double clicking it :slight_smile:

At least it worked for me :wink: Let me know if you think something might be missing in this process, else it should be good to share this solution widely :wink:


I had the same problem on Ubuntu 17.04.
The .x86 game just would not start.

To fix it I created a 64 bit version of the game (x86_64), then followed the advice to allow execution of the executable, and it worked.