How to run Unity3D on Manjaro Linux with Bumblebee (Optimus)

Hello! I’ve downloaded Unity for Linux and I am able to run it just fine, I’ve tested everything and everything works. Only problem is, when I do optirun ./Unity (in the main directory of Unity), the only thing that runs on my NVIDIA GPU is the Unity launcher, and not the actual editor, thus optirun is useless. How can I run the editor on my NVIDIA GPU? I need that performance boost badly :slight_smile:

NVIDIA Prime drivers are out of the question as they break the whole OS

I have same problem with archlinux under a lenovo y720 with a GTX 1060/Intel video cards.

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] (rev ff) 

When run:

$ optirun /opt/unity-editor/Editor/Unity

or

$ cd /opt/unity-editor/Editor
$ optirun Unity

I can view launch window but unity editor closes when select any project.

Any idea?

Using debug mode:

$ optirun --debug /opt/unity-editor/Editor/Unity
[ 1577.664030] [DEBUG]optirun version 3.2.1 starting...
[ 1577.664072] [DEBUG]Active configuration:
[ 1577.664078] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 1577.664084] [DEBUG] X display: :8
[ 1577.664089] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia:/usr/lib32/nvidia:/usr/lib:/usr/lib32
[ 1577.664094] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 1577.664100] [DEBUG] Accel/display bridge: auto
[ 1577.664106] [DEBUG] VGL Compression: proxy
[ 1577.664111] [DEBUG] VGLrun extra options: 
[ 1577.664118] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib32/primus
[ 1577.664161] [DEBUG]Using auto-detected bridge virtualgl
[ 1577.996693] [INFO]Response: Yes. X is active.

I have same problem with archlinux under a lenovo y720 with a GTX 1060/Intel video cards.

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] (rev ff) 

When run:

$ optirun /opt/unity-editor/Editor/Unity

or

$ cd /opt/unity-editor/Editor
$ optirun Unity

I can view launch window but unity editor closes when select any project.

Using debug mode:

$ optirun --debug /opt/unity-editor/Editor/Unity
[ 1577.664030] [DEBUG]optirun version 3.2.1 starting...
[ 1577.664072] [DEBUG]Active configuration:
[ 1577.664078] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 1577.664084] [DEBUG] X display: :8
[ 1577.664089] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia:/usr/lib32/nvidia:/usr/lib:/usr/lib32
[ 1577.664094] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 1577.664100] [DEBUG] Accel/display bridge: auto
[ 1577.664106] [DEBUG] VGL Compression: proxy
[ 1577.664111] [DEBUG] VGLrun extra options: 
[ 1577.664118] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib32/primus
[ 1577.664161] [DEBUG]Using auto-detected bridge virtualgl
[ 1577.996693] [INFO]Response: Yes. X is active.

Any idea?

optirun fails, but primusrun works for me on a GTX 1050. Running the latest Manjaro i3 with 384.111 drivers.