How to set compression on 2d animation clip?

I’m testing the new 2D animation system…
made a 2d character and animated it with old ( gameobject) legacy animation, and with new 2SAnimation package, Skinned 2D- sprites and animated it.
However, even though the skinned sprite uses a lot less bones, and keyframes, the animation clip file is 4X as large.
I went looking for animation compression settings but cant find any.
so 2 questions…

  1. Why would the clip be much larger on disk for skinned character test, even though the number of keys and bones is smaller ?

  2. Is there a way to turn on compression? the inspector window for the clip is pretty much empty. it only shows wrap mode. thats it. Debug view mode shows more… but compression is greyed out wether animation is set to legacy or not.

a 2 second idle loop is >1mb. that is not sustainable…
any ideas ? thanks.

looks like unity only allows compression of animations in .fbx file’s import settings… 3D objects only.
Not for 2D animations, or .anm file clips created to animate, gameObjects, sprites or Ui.