How to set up shadows on Nexus 10

Hey the Title pretty much says it all, I’m looking for some help setting up shadows. I’ll list some of the things I’ve done, hopefully you guys can can tell me what I’ve missed or something like that :slight_smile:

I’m using the trial version of Unity Pro which as far as I know contains Unity Android Pro
My hardware is a Samsung Galaxy Nexus 10 with an ARM Mali T6xx
I’m running the Scene with Graphics Level OpenGL ES 2.0
I’m using Forward Rendering

My Scene has one rotating directional light (Hard Shadows Enabled)
A Plane and a few cubes
A Capsule with player controls to move around
A Fixed Isometric Camera

Shadows appear on my PC but when I build and run the game on my Nexus 10 shadows aren’t there, other than that the game runs the same on both platforms.

I’ve read some of Unity’s documentation on Android Development and Shadows and from what I’ve read it should be possible.

Thanks for reading and Thanks in advance for your assistance

Please let me know if you need any more information if you would like to help :slight_smile:

I am targeting an android device for building.

Build Settings :

Texture Compression : Don’t Override

Google Android Project : false

Development Build : true

Autoconnect Profiler : true

Script Debugging : false

Player Settings :

Resolution and Presentation


Default Orientation : Landscape Left

Status Bar

Status Bar Hidden : false

Use 32-bit Display Buffer : true

Use 24-bit Depth Buffer : true

Show Loading Indicator : Large

Splash Image

Splash Scaling : Scale to fit (letter-boxed)

Other Settings


Static Batching : true

Dynamic Batching : true

GPU Skinning : true


Bundle Identifier : com.Company.ProductName

Bundle Version : 1.0

Bundle Version Code : 1

Minimum API Level : Android 4.2 ‘Jelly Bean’ (API level 17)


Device Filter : ARMv7 only

Install Location : Automatic

Graphics Level : OpenGLES 2.0

Submit HW Statistics : true

Internet Access : Auto

Write Access : Internal Only

Scripting Define Symbols : 5


Api Compaibility Level : .NET 2.0 Subset

Stripping Level : Disabled

Enable Internal Profiler : true

Optimize Mesh Data : true

Did you choose Android as the Target platform?

I’ve managed to fix this myself
I made sure all the Quality settings were what I wanted them to be and that they were all compatible with my hardware

If anyone else runs to this problem just check your Quality Settings make sure Hard Shadows Only is ticket etc…