How to set Visual Studio 2010 as default script editor in Unity


I am starting to learn how to use Unity.

I am following some good tutorial videos from 3D Buzz, and they are using Visual Studio 2008. 3D Buzz

I want to follow on, so I have downloaded Visual Studio 2010 C# Express, but unlike what they do in their videos, I can't get Unity to use Visual Studio Express as the default script editor.

I am hitting Edit --> Preferences ... --> External Script Editor. But how am I supposed to select Visual Studio Express? Do I need to navigate to the file itself on my hard drive, and if so, can you please help me find it? I have searched through my folders, but there are simply too many in the Microsoft Visual Studio Express that I don't know which one to choose. Keep in mind that I am also new to Visual Studio Express as well.

Thank you in advance.

Screenshot of the windows

OK I found the solution... It's pretty simple and pretty much works just as it should, it just doesn't TELL us that its working!

Here you go: (tested with latest version of Unity 3 (downloaded it on 18th feb 2011; and VS2010 Express):

1 . Edit --> Preferences ... --> External Script Editor -> "C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\vcsexpress.exe"

So far so good right, everyone's doing just this... Well... its already working! you just don't know it!

2 . right-click your script file -> "Sync MonoDevelopment Project" - YES, it SAYS "MonoDevelopment", but what it really means is "Visual Studio Express"; so go for it and click it

double-clicking script files will still open mono, so here you give up... forget double clicking the files...

3 . open your project folder in windows explorer and your VISUAL STUDIO project (".csproj") and solution (".sln") files are sitting there; open the project file and visual studio will do the rest; with INTELLISENSE and everything!

Now we just don't have the ease of clicking stuff in Unity to open in VS, we have to go into VS and manipulate files ourselves; but its no biggie really... :-)

You aren't allowed to open VS Express from within Unity (even though you can browse and select it in preferences) you'd need VS Pro or some other version of VS. The reason why intellisense might not work is because you haven't sync'd Unity to your VS project.

There is now a page in the doc´s explaining how to get Unity to work with Visual Studio Pro or Express. Read up on it here.

I know this is an outdated thread, but I have some links that will help out with future versions such as VS 2012 and 2013.

This tutorial makes it much easier: Configuring Unity to use Visual Studio 2012/2013 by Michael H.C. Cummings

And if you want the tools for more power, download it here: Visual Studio 2013 Tools for Unity - Visual Studio Marketplace

Be sure to have VS Community installed first.

I am using VS community edition.
I used the path below-
“C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\devenv.exe”

Ok, I think I found it via "C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\vcsexpress.exe"

Now I have another problem, however, that when I open up a script in Visual Studio Express, the autocomplete intellisense doesn't work.

I don't know whether this is a Unity or Visual Studio related question, but in the video when he types "transform.", a box appears and shows him a bunch of options like "transform.position.x".

Does anybody know how to enable this feature? I have tried to press CTRL+ALT+SPACE (I Googled it), but it doesn't work.