How to Stop Banding

Hello, I have my 3d First person game i’m currently working on. When I play it, if I look (even on the standard cube) at an object, it gives a banding effect which I prefer being smooth. To show you what I mean, look at the one on the left side (8 bit gradient):

how do I make smooth like the 24 bit one?

You need to go to the texture file, and in the inspector do this:

Shadow Resolution has a significant effect on banding on textureless objects like the standard Unity cube. Try changing it to “Very High Resolution” in Edit > Project Settings > Quality, or in your light source if it overrides that default.