How to stop 'sphere' shade to get polly look?

Hey guys, I am making dynamic verts/tris from script and I keep getting this linear fall off kind of effect, I know there is a way to stop it from thinking it’s a sphere but I cant remember how to stop this. Can you remind me. even the name of what is going on there to make it look like a sphere.


what I am trying to get it to look like.

What you are looking for is flat shading.

What you need is this article: Go Beyond Retro Pixel Art With Flat Shaded 3D in Unity

You need to duplicate the vertices in your model so that vertices are not shared between faces (that’s what makes Unity create the “smooth” effect on faces, since it is interpolating between the normals) and, rather, each vertex shares the same “face normal”.

You can either split the vertices in your modelling program or ask Unity to do it on import by setting Normals to “calculate” and smoothing angle to 0. However, note that increasing the vertex count may break dynamic batching if it takes you over the 900 vert attributes per object limit.

Alternatively, you can write a custom shader that calculates light reflection of each poly based on a surface normal - which is more work and less flexible, but offers better long-term performance.