How to stop textures from getting blurry?

Hello everyone!

I’m making a 2d isometric game and for that I’m using sprite sheets for the characters. But every time i try to apply it to a cube/plane i get a blurry texture.

These are the images/settings I’m using:

alt text

(these are the results, what i get from unity in the left side and what i want in the right side)

alt text

(this is the sprite sheet I’m using)

alt text

(these are the material settings)

alt text

(these are the image settings)


I know that this was answered before and that people say that to fix this my textures must have a size of power of 2, but in some cases that’s not very good for performance or for the pixel image itself, so is there any good way of doing this? (a way of fixing the blurriness and not cause any other problem later)

Thanks in advance!

Also Set your Sprites Filter to “point”. I did this and all my sprites look crystal clear, even though they are scaled 4x

I scaled the sprite sheet up to 4096x512 using gimp and the quality was improved a lot, but I couldn’t find a way of fixing the blur.


Also if you’re making a 2D game this shader might be of use:

Uncheck Generate min map and set format to TrueColor