How to use Android SDK?

Hello folks.
So, I’m running into some problem; I can’t seem to make the Unity Remote 5 work, and that’s because of SDK (I suppose).
I’m not very expert at the subject and I need some help from someone more experienced.
I installed SDK with Unity (what seems to be useless, because Unity doesn’t recognized this and showed me the message “Set-up Android SDK path to make Android remote work.”)
Well I had installed SDK with Unity so it should know where the F***ing SDK is, right? But no, it didn’t. So I went to the Android Developer site and downloaded the SDK tools (now I have two). This didn’t come with an installer as I saw in some tutorials, it just came with a folder with some files. I put this on Unity’s SDK path, and the message in the console didn’t appeared anymore, but still the game doesn’t show up on my phone.
The phone is recognized by the pc, it is plugged on the motherboard USB, it has USB debugging on and in the Unity Project settings I have Device set to “Any Android Device”, which is the only option I see.
I’m for two days trying to understand how to do it with no success, please help!!
Thank you in advance.

Isaac

that issues feels more like a problem with the sdk than a problem with unity . can you try finding your device? you need to go to the sdk path and find the folder build tools and inside there open the cmd (File/Open Powershell or cmd or something like that) then try running this command :

adb devices

it should show a device conected. if it doesnt appear (most likely will not) then it means the sdk cant find the device, after you plugged the phone and enabled developer options are you 100% sure you ACEPTED the prompt that appear when you first connected your mobile to the pc? since you MUST enable each pc even if you have usb debugging on. if you are not sure you can revoke solicitudes (i am not sure what the option will be in english but something like that for sure and its next to the enable debugging option) and make sure you accept the computer for debugging. you may need to wait some seconds for the small window to prompt in the phone, if it doesnt prompt it means that the issue is not most likely with the sdk but with the ADB drivers, before trying to install new ADB drivers try downloading the build tools folder from the android SDK since if you are using a new android version the build tools might be obsolete. tell me if you have any issues

@xxmariofer I tried opening Pwershell from the build-tools folder and running adb devices , but it might not have workd as expected, look:

I also tried with cmd:

Didn’t worked as well…
Both say “adb” is not recognizable.

I’m sure I accept the prompt when I first connected my phone to the pc.
I also did the “Revoke USB debugging authorizations” thing just to make sure, and connected again… Still Unity Remote doesn’t work.

My Revoke option in my mobile, and the popup that appears when I click it

“and make sure you accept the computer for debugging” – I don’t get that, where do I accept it? Can’t see that option.

“you may need to wait some seconds for the small window to prompt in the phone, if it doesnt prompt it means that the issue is not most likely with the sdk but with the ADB drivers” –
–The only small window that I see in my phone is this one when I first connect him to the pc. Which I made sure I clicked “yes”.

“before trying to install new ADB drivers try downloading the build tools folder from the android SDK since if you are using a new android version the build tools might be obsolete.” –
–How would I install new ADB drivers? And And I already tried downloading the build-tools folder from the Android Developers site…

@xxmariofer This is what appears when I run “adb devices” in cmd from the platform-tools folder with my phone connected:


It shows a string of letters and numbers and then “unauthorized”…

If I do it without the phone being connected the list is empty, so I assume this “unauthorized” item is my phone!

What does this mean please? And what should I do from here? I appreciate your help.