how to use EditorObjExporter .obj-saving-script from the wiki?

i’ve just tried the EditorObjExporter.cs to export a mesh visible in the player window.

i copied the script to Unity/Editor but i cant see anywhere an option called Custom>Export mesh?

where is “custom” supposed to appear, in edit menu?

/* Based on ObjExporter.cs, this “wrapper” lets you export to .OBJ directly from the editor menu.

This should be put in your “Editor”-folder. Use by selecting the objects you want to export, and select
the appropriate menu item from “Custom->Export”. Exported models are put in a folder called
“ExportedObj” in the root of your Unity-project. Textures should also be copied and placed in the
same folder. */


Try with this package :slight_smile:


Well, this should appear on the Unity main menu (the one that has “File”, "Edit, “Assets” , etc), if the objectexporter script is on an “Editor” Folder it should appear already, you could try also close Unity and open it again to let it refresh the customs menu.

Also the “Editor” folder where the script it’s placed on, have to be with the first letter in capital.

Hope this help,


Hi, this works to get the “level” part of e.g. Snowbox ServerWorld1,

but it doesn’t work for something like this Humpback Whale from the asset store:

When I select the whale and do custom->export (any option) the output files are nearly empty.

Actually, first, the export feature says I have to select an object with a mesh filter. I’m pretty new, and can get confused as to what that entails exactly, but I added, in component->mesh->mesh filter, and also tried adding mesh rendered, and then the export feature does not complain, but, ya, as stated, the output files are nearly empty, and loading them in e.g. 3DS Max, it says “nothing to import”.

Any tips? Thanks!

Humpback Whale
Select the humpback whale in scene, and in inspector ‘add component’ mesh filter,
then drag humpback_whale_exp1_0 MESH the thing with the square grid icon into mesh filter
‘mesh’ area, it will export to obj now. Still have no clue what a mesh filter is, there’s
on one on my washing machine water hose though. ;–]

Make sure both of the files outlined in the wiki page are in the editor folder together. It did not work for me until they were both together.
Once I moved them in the editor folder together the custom option on the menu bar showed up and I was able to export my .obj files.