HTC Vive very laggy in editor. Laggy hands and stuttering. Profiler shows a lot of lag spikes from editor.

Hello Everyone,

I’m currently working om my very first VR project and for some reason my HTC VIVE is not behaving like I expected. In editor when I’m in playmode my game is sometimes very laggy. It often returns to the screen when not in game.

Especially the hands are very jittery and choppy if you guys know what I mean. I have been looking all over the place but can’t seem to find anyone with the same problem. Some seem related but they don’t behave in the way my problem is behaving. My profiler shows a lot of lag spikes from the editorloop.

For some reason I also have a problem with some shaders turning greenish(cyan) when they appear for the first time. All very weird problems in my opinion and I am lost. I have no clue where to find them. If anyone could help me or point me in the right direction I would be very thankful.

Cheers and thanks in advance!

Allright so I think I know what i was seeying here. It did not have to do anything with my game running badly. The lag spikes you see are from the ‘other’ category. After I profiled the editor (instead of playmode) I came to the conclusion that they are the editor repainting all the windows. I found this in the following thread: https://forum.unity.com/threads/editor-loop-why-is-it-causing-452-ms-delay.727526/

I found out that even a clean project has these lag spikes from the editor repainting all the windows. However my game still runs very badly and my hands and stuff are still jittering I know that it hasn’t to do anything with these lag spikes now. These lag spikes seem quite harmless.

I will keep trying to figure out what makes my project run so badly and keep posting updates if I find anything new.