Hub 3.0.0 Cannot Activate Licenses

I'm running into a critical issue where the latest release of the hub will not activate any licenses (either a personal or professional license). This is occurring on the new release of the hub v3.0.0 (not beta).

This is unfortunately preventing me from any progress, so a quick update is much appreciated.

4 Likes

this happened to me today, anyway to fix it ?

1 Like

lo mismo error. It does not recognize my personal license, it is not active, it does not work at all, when opening the editor, license error, unusable!.
manual activation does not work either.

Hello,
Sorry about the inconvenience you are facing.
Could you please share with us your Licensing Client and Hub logs

They are located under:

Windows:

  • Hub: %APPDATA%\UnityHub\logs\info-log.json
  • Client: %LOCALAPPDATA%\Unity\Unity.Licensing.Client.log

MacOS:

  • Hub: ~/Library/Application\ Support/UnityHub/logs/info-log.json
  • Client: ~/Library/Logs/Unity/Unity.Licensing.Client.log

Linux:

  • Hub: ~/.config/UnityHub/logs/info-log.json
  • Client: ~/.config/unity3d/Unity/Unity.Licensing.Client.log

You can send them to me in private if you wish so

1 Like

Same here. I just filed a report through the Hub's troubleshooting bug panel.

[quote=“Matin”, post:4, topic: 867822]
Could you please share with us your Licensing Client and Hub logs
[/quote]
I just sent these via a private message. Keep us posted!

having same issue :( cant open my project on my day off from work

my unity.licensing.client.log states
2022-01-11 23:48:19.922 - [ 18056] - [ 7] - INFO - Unity.Licensing.Client.Communication.Controllers.AccessTokenController || Got access token: -HST8Rpm5LqdzXBmFuvgWI4jtXdtWhaAJleADUx3gb4001f (expires in 30758400 seconds)
2022-01-11 23:48:19.922 - [ 18056] - [ 7] - INFO - Unity.Licensing.Client.Communication.ApiPipeHandler#1 || [Response] Type: AccessTokenResponse, Code: 200, Status:
2022-01-11 23:48:19.923 - [ 18056] - [ 7] - INFO - Unity.Licensing.Client.Services.Licensing.GenesisLicensingService || [9ca2ab7a16e342efa90bcbdea94a6f2b] Starting Ulf transaction for NEW operation
2022-01-11 23:48:20.616 - [ 18056] - [ 19] - WARN - Unity.Licensing.EntitlementResolver.ContextBoundDataExtensions || The following fields of your context don't match:
Legacy.MachineBinding4: License value (NULL) != Current context ()
2022-01-11 23:48:20.617 - [ 18056] - [ 19] - ERROR - Unity.Licensing.EntitlementResolver.ContextBoundDataExtensions || Legacy MachineBinding validation failed.
2022-01-11 23:48:20.617 - [ 18056] - [ 19] - ERROR - Unity.Licensing.Client.Services.Licensing.GenesisLicensingService || [9ca2ab7a16e342efa90bcbdea94a6f2b] An error occured while performing the ULF NEW operation: Machine bindings don't match
2022-01-11 23:48:20.617 - [ 18056] - [ 7] - INFO - Unity.Licensing.Client.Communication.ApiPipeHandler#1 || [Response] Type: ULFActivationResponse, Code: 1400, Status: Machine bindings don't match
my programdata/unity also appears empty after this update

it fixed it when i restart the pc now it works

[quote=“HAZIM_REAL”, post:9, topic: 867822]
it fixed it when i restart the pc now it works
[/quote]
wish i could say same

[quote=“HAZIM_REAL”, post:9, topic: 867822]
it fixed it when i restart the pc now it works
[/quote]
Didn’t fix it for me.

Hello I also have the same problem and I'm crazy I have about 3 hours trying to activate it any solution?

Same

if it wasnt for the fact that they dont let you open a unity project without a license it wouldnt be such an issue. but no response here, on my help ticket or anywhere. i have already found posts of people leaving unity over this. if i havent already spent so much in the asset store i would be working on porting my stuff to unreal also. the fact that an issue this big and no response is mind blowing. i have been working and trying things for about 24 hrs and my love for this game engine is almost gone.......not 1 word from unity about this situation people are having with the hub update they released.

2 Likes

[quote=“tredpro”, post:14, topic: 867822]
if it wasnt for the fact that they dont let you open a unity project without a license it wouldnt be such an issue. but no response here, on my help ticket or anywhere. i have already found posts of people leaving unity over this. if i havent already spent so much in the asset store i would be working on porting my stuff to unreal also. the fact that an issue this big and no response is mind blowing. i have been working and trying things for about 24 hrs and my love for this game engine is almost gone…not 1 word from unity about this situation people are having with the hub update they released.
[/quote]
I am a new user (well, so far I’m a new nothing as I haven’t been able to use the software at all…), and this is definitely not the best impression they could make. It could be as simple as making the previous version available as they work on the current flawed one, but it looks like they don’t do that, so right now everyone who has a problem is stuck. I also raised a ticket through the bug platform too, but no acknowledgement of the issue yet. I’ve wiped the system and installed again, even though it was already a fresh install the first time, and it solved nothing except waste my time. Auto or manual activation, neither works. I don’t know man.

1 Like

[quote=“sab_the_cat”, post:15, topic: 867822]
Я новый пользователь (ну, пока я не новичок, поскольку я вообще не мог использовать программное обеспечение…), и это определенно не самое лучшее впечатление, которое они могли произвести. Это может быть так же просто, как сделать предыдущую версию доступной, пока они работают над текущей версией с ошибками, но похоже, что они этого не делают, поэтому сейчас все, у кого есть проблема, застряли. Я также поднял тикет через платформу ошибок, но пока не получил подтверждения проблемы. Я очистил систему и установил снова, хотя это уже была новая установка в первый раз, и она ничего не решила, кроме как тратить мое время. Автоматическая или ручная активация не работает. Я не знаю человека.
[/quote]

Я сделал то же самое, потратил день на поиск проблем и переустановку системы. Только сейчас решил зайти на форум и убедиться, что проблема не только у меня

[quote=“sab_the_cat”, post:15, topic: 867822]
I am a new user (well, so far I’m a new nothing as I haven’t been able to use the software at all…), and this is definitely not the best impression they could make. It could be as simple as making the previous version available as they work on the current flawed one, but it looks like they don’t do that, so right now everyone who has a problem is stuck. I also raised a ticket through the bug platform too, but no acknowledgement of the issue yet. I’ve wiped the system and installed again, even though it was already a fresh install the first time, and it solved nothing except waste my time. Auto or manual activation, neither works. I don’t know man.
[/quote]
i have been using unity since unity 3 and this is a new issue. back then your unity install was the free version and you would install a pro version if you wanted that. if i was new, i would be using unreal personally. especially after this. they are literally able to lock me out of work ive been doing for years and i cant even open unity to export or anything without a license.

On MacOS Monterey:

I was connected to a VPN to access my client source control:

Hub was not working only blank screen.
Cleaned everything in Library/Application Support/Unity and Hub, Desintall hub and reinstall
Still blank screen .

errors in hub info-log.json :
getaddrinfo ENOTFOUND core.cloud.unity3d.com
getaddrinfo ENOTFOUND api.unity.com

Disconnected from VPN ( TunnelBlick ) and bang eveything works fine.

1 Like

[quote=“Packedbox”, post:18, topic: 867822]
On MacOS Monterey:

I was connected to a VPN to access my client source control:

Hub was not working only blank screen.
Cleaned everything in Library/Application Support/Unity and Hub, Desintall hub and reinstall
Still blank screen .

errors in hub info-log.json :
getaddrinfo ENOTFOUND core.cloud.unity3d.com
getaddrinfo ENOTFOUND api.unity.com

Disconnected from VPN ( TunnelBlick ) and bang eveything works fine.
[/quote]

yea ive tried connecting then disconnecting vpn and no luck :frowning: glad it worked for you and i hope it does for others

hub loads. i just get error

There was a problem activating a new personal license. Make sure you are logged in, and have internet connection.

when trying to create new license