i am having problem with MonoDevelop

I want MonoDevelop to be my default program when i open scripts in my asset folder but it won’t select it as my default, it will select anything else expect for the program, why is that?

Using Windows? Right click, Select Open as>Choose Program, mark the checkbox to always use the program and search for /Unity/MonoDevelop/bin/MonoDevelop.exe