I can see trees, even when there is no light

how you can see the trees at my terrain are visible, even when there is no light.
Is there a way to fix it?

Go to Edit → Render settings and change Ambient light to complete black. It’s dark grey by default, that’s why you can see your trees.