I can stand on top of my cave model but fall through upon enter

I have a feeling I’m doing the colliders wrong. I didn’t group all the components together before exporting in Sketchup if that’s the cause. I’ve uploaded a video on youtube showing my model being imported or atleast how I think I should be importing it and then how I can stand on top of it but not inside it. The model is a cave, forgive me my modelling skills are not good at all but it is meant to be a cave.

When I import the model (via drag drop 3ds from model folder) I see it listed as Cave > Model > Mesh01-0x, could someone explain to me a little about the meshes? I am a newcomer to Unity and after reading several pages here on Unity Support I can’t get to grips with it. I’ve read that the basic thing is to attach the mesh colliders and then your model will become physically static rather than being able to walk through it. However my model has a bunch of mesh’s followed by a number and I have no idea what that means. If I just add a mesh collider for each of them, I can now stand on top of the cave without falling through. But I still can’t jump inside it or spawn inside it having moved the character controller and placing a small box collider beneath the controller holds me in place yet if I jump off further or farther out the cave I still fall through. I understand I probably sound rather confusing which is why I made the video, so I could explain the problem without hurting your eyes.

Also when I look at it from the scene view after scrolling the camera to zoom inside the model most of it disappears as if I had hit the play button with the character controller inside or outside the cave yet if it’s placed on top of it I can see that it does appear. I would really appreciate some help Thanks for the support and apologies for the bad grammar.


I looked at a few video’s and it turns out I was just using the wrong format (.3ds) which had worked for me in the past I guess the colliders is just a little bit tricky. With FBX I used the generate colliders option and it worked flawlessly, I hate to answer my own question but thanks. Maybe someone will find this useful.